Hello

I have the most weird and annoying tab prob ever !
So, I use my tab only to surf etc. not done any modifications and such.

One evening I put the tab on the charger and went to sleep, as I always do.
Next morning tab is non responsive.
No battery icon, nothing. just a black screen, buttons not working.
its all black and stays that way.
Plugged in charger again , no battery icon.

What I have done so far.....

tried different button combo's
re seated all cables inside.
connected to pc, all button combo's pc sees as unknown device APX
tried nvflash, odin, samsung kies. adb just to see if device is recognised but no. tried many different drivers, connected to another pc,
same result, unknown device apx.

got a new original cable
got a new battery
got a new charging port
same result... unknown device apx

googled for weeks trying to find out what was going on, I doubt it is bricked as I have never changed and or modified anything.
contacted samsung and of course their only option was to take it to service center . duh. I seriously doubt they even knew what I was talking about...

I am out of idea's now. I noticed nothing wrong before it went dead.

Is there anyone out there who can help me out please ??
or steer me in the right direction or give advice pleaseeeeeeeeeee

Or is the life span of my tab used up ? tab is from 2011 I think.

Thank You